Empathy MSN bug

Yesterday I noticed that one of my two MSN accounts wasn’t logging in but instead was returning the error message “No Reason Specified”, which isn’t all that helpful really. I wasn’t overly worried because to be honest I don’t really use MSN, it just idles when ever my machine is on, much like my Yahoo and AIM accounts. I use Google Talk and Facebook Chat on the whole, with the odd venture into Skype.

Anyway, today the second account started giving the same error, so I decided something must be wrong, and I should take a look. If nothing else I wanted to find out whether it was me or something that needed raising as a bug. It looks as though this is a general problems and there should be a bug fix to the python-papyon package on the way, but to summarise the details from Ubuntu bug #664570:

Find the file

/usr/share/pyshared/papyon/service/description/SingleSignOn/RequestMultipleSecurityTokens.py

and edit the line

CONTACTS = ("contacts.msn.com", "?fs=1&id=24000&kv=7&rn=93S9SWWw&tw=0&ver=2.1.6000.1")

and replace it with

CONTACTS = ("contacts.msn.com", "MBI")

Personally I always leave the original line there as a comment for reference or backout purposes :)

Then restart Empathy and you should be fine.

21 Oct 2010

Little Bang

Just have to add a link to this. Dawn and I saw the Bang Goes the Theory pykrete ice boat experiment as it happened down in Gosport, but Aaron and Scott missed out as they were at school. So, when the weekend came we decided to repeat it in miniature. Dawn tweeted some photos we took, and @bbcbang asked if they could use them in the live show on the red button after the programme on BBC1.

So, if you take a look between 16:10 and 16:40 (roughly), you’ll see Aaron and Scott’s very own pykrete ice boat experiment featured – they we very excited about it! I love the quote from Yan to Jem at the end “do you take apprenticeships”, followed by Jem’s reply “they’re already way ahead of me” :)

15 Oct 2010

Not to blame for Windows 7

In contrast to the wonders of the recent Microsoft advertising where everyone is trying to claim responsibility for Windows 7 (is it just me that sees this, along with the terrible launch party idea, as a desperate attempt to build the sort of community that open source software has?), I would like to make it publicly known that Windows 7 is not my fault. I’ve been working on installing it recently, and really don’t want to be associated with the palaver involved in doing so!

First off, it totally fails to recognise the controller my hard disk is attached to, so I have to add it in on install. This is a Silicon Image 3512 based SATA PCI card, and it also failed to recognise the ITE 8212 PATA card I tried. Once I’d installed I found that it seemed to think I had a USB2 CDROM drive attached, which I don’t, I don’t have one (well, bar a case in a box that is waiting for an ATAPI DVD-RW to be installed!). It also failed to detect my network card.

So after a reboot, just in case, I decided to take a further look. It seems that Windows 7 lacks drivers for my NIC (SIS 900), SCSI card (Adaptec 2940) and sound card (AC’97, either Realtek of SiS, depending on whether you believe the Gigabyte website or lspci!). The NIC and sound are on the motherboard, whilst the, admittedly old (it was purchased when I built my first 486!) SCSI card is PCI,

So, after some fun with Google, and a bit of downloading, I installed a Windows XP driver for the SiS900, and tried Windows Update. This found 22 updates, totaling around 155M give or take, and proceeded to install. Sadly, 5 updates failed to install properly, including the updated SiS900 driver and the AC’97 audio driver!! The others were the SiS AGP driver, Windows Malicious Software Removal Tool and updates for Windows Defender. Nothing critical then, just network and sound drivers and protection from anything nasty (which you won’t need with no network will you!).

Thankfully, after a reboot, another run of Windows Update, and another reboot, I seem to have a basic install of Windows 7 that works. I just need to decide what to do about the SCSI card, sort out anti-virus, and adjust my network settings (for some reason I seem to have been connected to two when I only have one, and I need to change the workgroup). Then I can start looking at getting some actual software installed to make the machine useful.

Anyone who claims Windows is easier to install and has better driver support than Linux really needs to think again!

26 Feb 2010

BIOS fun

Isn’t playing with a computer BIOS fun? No? Of course it is!

I’m rebuilding my main desktop system at the moment. It isn’t anything spectacularly new, in fact it is based on a Athlon XP 2800+, but it runs Linux (Ubuntu 9.10 currently) with ample performance for my day to day tasks. Windows XP runs on it adequately, when it actually works (I clearly use it too little because it sulks and ‘blue screens’ every few months, requiring a repair or reinstall).

Anyway, as part of this rebuild I decided that it made sense to get everything bang up to date, including the BIOS. The board is obsolete now, so the BIOS was a few years old and should be stable enough – wrong! The board is a Gigabyte GA-7S748-L (GA-7S748 with on board LAN), and was running the F5 revision. Updating was simple enough, just boot of my DOS USB key (yes, I have a USB key with DOS installed!) and run the utility. This brought things up to revision F9, which was the latest, and is where things started to go wrong.

The first thing I noticed was that my Windows 7 installation couldn’t see the HD, so I reached for a driver (Vista was the most up to date) to add during the install process. This didn’t work, and further investigation showed that the BIOS of the PATA PCI card the drives were connected to wasn’t active. It turned out that enabling USB legacy support disabled the card BIOS. Unfortunately, in order to configure the card BIOS you needed a keyboard, and since mine was a USB one, USB legacy support was required to use it – catch 22!! After trying a PCI SATA card instead I found that this was clearly a motherboard issue and not specific to one card or chipset.

So the next thing to do was to back off to the previous BIOS (F8 in this case) to see if the bug had been introduced in the latest BIOS upgrade. Unfortunately it seems that the F8 BIOS was completely bug ridden (so it is a shame it is still available for download). After installing it the computer wouldn’t boot at all, although it would allow use of the BIOS itself. This board has a facility to flash the BIOS from a BIOS based utility (Q-Flash), which sounds pretty handy in this case. Sadly it didn’t work, although thankfully, the failure didn’t damage the installed BIOS any further. After a bit of research with Google, I found that if you disable USB support completely you can boot to a floppy and re-flash the BIOS using a DOS based utility (will DOS ever die?!).

So, with this information I managed to get back to the F5 BIOS and all was working again. Out of curiosity I then tried the F6 BIOS and found that the USB legacy support clash with the PATA card BIOS was introduced there, so presumably exists in F7 too. Back to square one again then, with the original F5 BIOS and a working PC!

26 Feb 2010

Microsoft to provide default Ubuntu search?

A while back I noted from Popey’s blog that Canonical are changing the default search engine in the next version of Ubuntu to Yahoo!. I don’t think I’ve been particularly impressed with the Yahoo! search since the 90′s sometime, when I switched to Google because it provided much easier access to the search results I wanted. This was largely because it was at that time unencumbered by advertising results being engineered into high listing placements. Sadly that isn’t the case today, and I have the same annoyance with Google providing endless ‘search noise’ in the form of links to price comparison sites, or links into a site search for the terms you’ve used on Google, generally with results that are totally irrelevant. That is beside the point for this post though.

I note from recent news that Microsoft and Yahoo! have been given the go ahead for their search deal, which means that Microsoft Bing should be providing the search results for Yahoo! by the end of the year.

Interesting times, since that would appear to indicate that the average new user of Ubuntu will be using a Microsoft search engine, and one that may not be as good for searching for information on Linux and Open Source software – although it has to be said I’ve not experimented with this myself.

20 Feb 2010

Protext now free

Nearly two years ago now, back in December 2007, I blogged about Protext. Protext is a word processor that started out life on the Amstrad CPC range of 8 bit micro computers, but also found homes on the Amstrad PCW, Atari ST, Acorn Archimedes, Commodore Amiga and PC running DOS. It also appeared on the Amstrad NC series of portable computers.

Anyway, the primary reason for that post was to provide a link to the new home for the website as I’d had a little fun tracking it down since Google links hadn’t updated (likely due to the site not having been removed by the ISP!).

There are two reasons for this follow up. Firstly to provide a track back to the original post and a link to the new location, since it has moved once more. I’ve been in touch with Mark Tilley again (who provided the link for me) and the Wikipedia page has been updated, which should help Google find it.

The second one is to make note that it is now a free download. It isn’t open source, but as a nostalgia point, and for those that still enjoy using it, the last version for the PC, Atari and Amiga is available as a binary download.

Oh, and again, I guess I should put the link in:

http://www.tigerteam.co.uk/protext/

07 Sep 2009

Moonlit memories

Apologies to those catching this through syndication and are expecting it to be Linux or computer related, but it is in a good cause.

I am going to be joining the Rowans Hospice Moonlit Memories Walk this year, which is a 12 mile walk from Southsea Castle, along to Portsmouth Historic Dockyard, back via Old Portsmouth, along to Eastney and back – with a few wiggles along the way just for good measure. It will all be starting at midnight on the 20th June, so being late at night will be adding to my general lack of fitness! Having just got the pack I’m wondering what I’ve let myself in for, but it is for a good cause so I’ll crawl if I have to!

As many visiting here will know Dawn’s dad died at the end of January after a battle with cancer. His last few weeks were spent at Rowans and the staff and volunteers there do an amazing job.

I’ve known Geoff, on and off, since I was born, and he was the best father-in-law / grandad you could wish for, so I signed up for this walk for Dawn and Geoff. Since then, however, the memories part of this walk have taken on more meaning with the death of my mum at the beginning of April, particularly as the Rowans chaplain spoke at her funeral.

I very much hope that as many people as possible will give generously as Rowans is a very deserving and worthwhile cause, and if you pay tax do make sure you use Gift Aid to get the tax donated too.

Many thanks,
Paul

To sponsor / donate visit http://www.justgiving.com/paultansom, and if you have any problems let me know as I have been told some people have had trouble, although that may be down to the complete failure of the JustGiving Facebook application!

08 Jun 2009

Windows crashed

OK, that’s not a particularly unusual occurrence, but this has been one of the more unusual crashes for me. Earlier this morning I went to the Windows machine to burn an ISO image. It’s not that Linux isn’t capable, or that Windows does it better, just that unfortunately at the moment most of my machines are in pieces and the one with the CD burner has an old and flaky Windows XP install on it.

Anyway, I had misplaced the Knoppix ISO file that I was going to use, got distracted and only got back to the machine later in the afternoon. Not a major problem, bar the fact that this machine tends to sulk if it is left unused and crash (its days are numbered once I get my other machines built!). This time all initially seemed well though, bar the fact that there was a message telling me that other users were logged on and was I sure I wanted to shutdown. Well, I was the only user logged on and I hadn’t asked for a shutdown. In addition to this I only download updates, so nothing should have happened automatically (although after a recent run in with Windows Genuine Advantage and several exchanges with Microsoft I did find their ‘fix’ had enabled automatic updates as a side effect a while back!).

So I told the computer not to continue and proceeded to locate the ISO. Unfortunately the computer was apparently still shutting down as each application vanished in turn and I was then logged off. That would have been merely annoying and resulted in an investigation as to what had triggered the shutdown, but I was left on the login screen. Well almost the login screen anyway. There was no ‘turn off the computer’ button (this is a family machine and hence uses the login screen with the picture for each user – great for kids). The other problem was that, even with valid passwords, I could not login to any account.

Well the machine got left for a while, another distraction, and when I returned there was a very old style password prompt to unlock the screen. Once I had done this I simply had a desktop background with nothing else, but I was able to bring up the task manager and reboot from there.

All this seems suspicious activity, but my anti-virus / anti-malware / anti-etc. software is up to date, and scans using it and online tools don’t show up anything. I also don’t use Internet Explorer or Outlook Express and am patched right up to date bar 3 items from Windows / Microsoft update. The three items are .Net 3.5 which fails to install because it fails the pre-requisite of .Net 3.5 being installed (?!), Internet Explorer 8 (which for some reason is a high priority update and not an upgrade), and Silverlight. This last one is both of no interest and incompatible with my CPU! I know it is incompatible because it is a requirement for viewing some of the information Microsoft told me look at regarding my WGA problem, so I did actually try to install it.

Oh well, all the more reason to replace the machine and use Linux :)

01 Jun 2009

School IT education

I’ll start this post off by stating that I’m not having a go at any specific school with my comments here, least of all the one that my son attends, and that I attended too many years ago to mention. My sons school is, in fact, a very good school, and I’m not just saying that because I am now a governor ;)

That said, let’s move on…

The other day my son came home and asked if he could use the computer. Nothing spectacularly unusual there, but shortly after logging on he came back to me asking if we had “the big blue W” on it somewhere. After a brief to and fro I ascertained that what he meant was Microsoft Word and that he wanted to show me something that he had done at school.

There’s a few points here. Firstly there is the comparison with when I was his age (he is seven). Back then I still had around 6 years until the ZX81 was launched and I got my first taste of computers. Now they are not only everywhere, but interconnected to the point where it didn’t even occur to him that the work he had been doing at school wouldn’t be accessible from home – bless him.

Secondly there’s the annoyance that from such an early age the ‘big blue W’ and Microsoft Word are synonymous with word processing. I keep trying to tell myself that he is only seven and they need to keep things simple, but it is still irritating. The end result of this was that I sat down and explained what a word processor was, and that even though I didn’t have the one he used at school I did have another one. I was encouraged by the fact that, when presented with OpenOffice he set straight to work trying to reproduce the same sort of document he had at school, and did so with no help at all – beyond a brief grumble that there wasn’t much clipart! (actually I did show him where that was).

The next question baffled me a bit, “do we have the internet?”. My response was to tell him that we did, and that he used it regularly! Then we headed down a familiar road, “no I mean the big blue e” :( So off we went down the explanation of what a browser was and that he was already quite comfortable using both Opera and Firefox, as was his younger brother (who is 3). In fact they are both rather too good at some of the games on the CBeebies, Nick Jr and BBC Dr Who websites! Still, they are also quite happy playing with Frozen Bubble or Tux Paint :)

15 Jul 2008

No sign of foxes

Sadly there seems to be no sign of our regular foxes this year. For a good few years now we’ve had cubs playing in our back garden by now, but we’ve not seen or heard any yet, so we fear the worst.

Earlier this year when I was chatting to a friend who lost their dog to having eaten something poisoned, which was thought to have been put down for foxes. That’s pretty unpleasant on both counts – somebodies pet was killed, and there seems little justification for killing foxes to me, but there’s no accounting for some people.

The first fox in our garden goes back a good few years now, and sadly we dubbed him Basil. There was a bit more to the name than simply being a fox though. When he first appeared I was doing some painting in the garden and he crept up and nicked my paintbrush!

There’s some shots that should convince most that foxes are loveable creatures in our family photo gallery.

01 Jul 2008